Announcement

Collapse
No announcement yet.

CEL and CODE P0456

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CEL and CODE P0456

    Car threw a CEL last night. Put code reader on it today and got P0456. Small evap leak. Any H owners got this before. After rwading up on it it looks like either a bad PURGE VALVE or a faulty gas cap. As my Z doesn't have a gas cap, maybe the spring loaded devise may be dirty preventing it from sealing. Anyone else had this code and if so what was the problem? Weather crummy right now so can't try anything until prob tomorrow. Appreciate any help.
    Bud Pytko
    2015 Lincoln MKZ Hybrid
    2005 Ford F250 6.0 PSD CC 4X4 LB
    2007 Arctic Fox 30' 5th Wheel


  • #2
    Hey, Bud!

    I think you're on the right track. I did a little googling myself, and found this link on a Focus ST forum.

    https://www.focusst.org/forum/focus-...ght-p0456.html

    Users there seem to have had luck getting it repaired under warranty, finding it is a solenoid, rather than the capless fuel filler.. If you still have warranty, a quick call to the dealer may get it done for you.


    Heh. Of course here's a different Focus forum, where they're sure it's the gas cap(less).... At least their fix doesn't sound so bad to try, so maybe start there? The thread above doesn't get too specific about exactly what valve gets replaced.

    https://www.focusrs.org/forum/27-foc...-code-fix.html
    Mike Martin

    1997 Mark VIII LSC 5.0
    2001 Dodge Dakota

    Comment


    • #3
      I went out and snapped the gas in cap a few times, turned off the CEL. Drove it out to my Doc's appt this morning and back About 15 miles total. Didn't come back on....YET !

      OH! Found out that the Remote Start will not work with an active CEL on !
      Last edited by budpytko; 02-21-2019, 01:22 PM.
      Bud Pytko
      2015 Lincoln MKZ Hybrid
      2005 Ford F250 6.0 PSD CC 4X4 LB
      2007 Arctic Fox 30' 5th Wheel

      Comment


      • #4
        OH! Found out that the Remote Start will not work with an active CEL on ! Also found out ya can not use the dumb "EDIT" function here !
        Bud Pytko
        2015 Lincoln MKZ Hybrid
        2005 Ford F250 6.0 PSD CC 4X4 LB
        2007 Arctic Fox 30' 5th Wheel

        Comment


        • #5
          I would check for any stored codes now to see if it may still have any codes listed? Sometimes certain issues require a certain number of fault cycles before triggering a CEL.
          JP

          Comment


          • #6
            Originally posted by budpytko View Post
            I went out and snapped the gas in cap a few times, turned off the CEL. Drove it out to my Doc's appt this morning and back About 15 miles total. Didn't come back on....YET !
            Emission codes may take a few engine cycles to come back if not fixed.

            Comment


            • #7
              emission codes require numerous monitors to reset to prevent emission testing "cheaters" from clearing codes around the corner from the smog test facility. Some take over 100 miles of driving.
              I suspect the purge valve as that seems to be the common issue with that code from the MKZ facebook pages. However, that being said...NEVER "top off"....when the pump stops, remove it.
              The most difficult part about taking a car in for warranty work with regards to a CEL, dealerships can be weird about it.
              1)the light HAS to be on
              2) you have to authorize the diagnostic (agree to pay for it) *if* the problem they find is NOT covered by your warranty
              3)the problem has to be "active", i.e. "doing it right now", not "a week ago" or they will say "we could'nt find anything wrong at this time, the car is working properly".

              I am always annoyed with how they deal with "warranty" claims with regards to CEL's...rather than give you the benefit of the doubt.

              I personally always clear codes for customers for free and then document the code in their car's file and explain to them "if the light comes back on, bring it in....I'll re-scan it. If it's the same code, I'll recommend you let is perform the needed diagnostic so we can find the problem and fix it".

              Keep us posted ok?

              Comment


              • #8
                As my appointment isn't until the 20th I went out and pulled the purge valve from in front of the engine. Did the blow/suck test and could NOT get air thru the value. Started the car with it removed and the CEL did NOT come on...replaced the valve, drove the car and the cell came back. After a couple of days the cell went out by itself !! OK...I 'll continue to drive it to see what it does. If it stays OUT, I'll cancel the appt a day or two before. Stay tuned.

                Oh, BTW, I felt that the screws holding in the valve felt loose.... guess it waited 3+ years to get any blow by. ??????
                Last edited by budpytko; 03-10-2019, 01:19 PM.
                Bud Pytko
                2015 Lincoln MKZ Hybrid
                2005 Ford F250 6.0 PSD CC 4X4 LB
                2007 Arctic Fox 30' 5th Wheel

                Comment


                • #9
                  I'll keep my fingers crossed for you!

                  BlackIce: Thanks for all the detail on your reply. It's invaluable to have someone with dealer/service experience around here. Your insights are appreciated.
                  Mike Martin

                  1997 Mark VIII LSC 5.0
                  2001 Dodge Dakota

                  Comment


                  • #10
                    The light never came back on...guess I'm home free !!! Thank you guys for the info I didn't seem to have needed ! LOL

                    BlackIce: I ALWAYS "top off" when I fuel up...but usually only to the nearest dollar ! When you only take 12 gallons if the tank is DRY...ya need all you can get ! I fill up about once a month - whether it needs it or not ! LOL
                    Bud Pytko
                    2015 Lincoln MKZ Hybrid
                    2005 Ford F250 6.0 PSD CC 4X4 LB
                    2007 Arctic Fox 30' 5th Wheel

                    Comment

                    Working...
                    X