Announcement

Collapse
No announcement yet.

Transmission overheat?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Transmission overheat?

    Sadly this may be the last post I make on the old '11 Crown Vic (320k). So yesterday I heard a quiet hiss coming from the front which turned out to be a very small radiator leak...in the middle of a fin somewhere. Doing errands around town today I kept extra coolant with me and added it as it needed. After filling it up I make a 60 mph trip to a nearby city about 20 miles away. When I get to a stop at the bottom of the off ramp, I hit the gas it it doesn't move. No extra lights on the dash except for the check engine light which was already on for something else. I put it in park and back in drive, tried all the gears but got nothing, not even in reverse. Thinking it might have something to do with my coolant situation I checked it and ended up putting in like 1.5 gal of coolant which is much more than it's taken before. Only thing I can imagine is that the leak got worse on the interstate and I didn't notice it. Did the no coolant issue cause the transmission to overheat somehow? There was a slight burning smell in the cabin so something definitely overheated. The overheat light on the dash never came on (I think I have one?) and the engine ran fine the whole time. I was traveling at 60 mph though so I wonder if that would be enough to cool the engine off while the transmission still overheated?


    What in the heck happened and what do I do, besides sell the damn thing.

  • #2
    Yeah I'll be trying to start her tonight for the first time so we'll see. Crossing my fingers.



    The other possibilities that have been mentioned to me so far is a broken input shaft or the MLPS, and I don't know what either one of these is. Was told if it ws the MLPS that it would be throwing a code. So wouldn't you know I'm having a problem getting it read. Wonder if there is a way to get a multi-meter on whatever the MLPS is and test it?

    Also, what is the input shaft and is it something in the drive line?

    Comment


    • #3
      Well, by now you'll probably know if she starts or not. These cars do have a whole bunch of "overheat protection" stuff build into them. it's entirely possible that it did over heat, and shut stuff down to save itself.

      Since you already topped it off, the only thing to do is wait, and start it later. If she starts/runs fine, buy that radiator and move on.
      Mike Martin

      1997 Mark VIII LSC 5.0
      2001 Dodge Dakota

      Comment


      • #4
        Wow after all this and it turns out to be the rear end. Just got it to my mechanic and he watched the driveshaft when I gave it some gas, in gear, and it turned. So I guess that's where the sound was coming from. Although my trans fluid smells a little, a mechanic who works on these crown vics a lot says the fluid always smells somewhat burned. I'm super easy on this car so I'm not sure why the fluid would smell like that. Newly changed out like 15k miles ago.

        Comment

        Working...
        X